Dotcpp  >  编程教程  >  基本输入输出  >  基本输入输出格式四

基本输入输出格式四

点击打开在线编译器,边学边练

接下来看第四种,对应1088题,A+B IV,这一题同样是求和,但是不是a+b两个数字了,而是求n个数的和,输入为先输入一个数组n,然后后面跟n个数字,求这n个数字的和。同样有多组数据,当n=0时结束。

样例输入:

4 1 2 3 4 
5 1 2 3 4 5 
0

样例输出:

10 
15

想必结合题意和样例,大家已经明白题目考察点了,就是累加求和,只不过个数n需要提前指定,为0表示结束,故而我们可以先接收n并且判断n非0再进入循环,循环n次累加求和


参考C语言代码:

#include<stdio.h>
int main()
{
  int n;
  int sum,temp;
  while(scanf("%d",&n) && n)
  {
      sum=0;
      while(n--)
      {
          scanf("%d",&temp);
              sum+=temp;
      }
      printf("%d\n",sum);
  }
  return 0;
}

注意本题,为双重循环,每次累加求和的sum一定要每次都要归零!这是一个易错点


参考C++写法:

#include<iostream>
using namespace std;
int main()
{
	int n,x;
	while(cin>>n && n)
    {
      int sum=0;
      while(n--)
      {
    	cin>>x;
        sum+=x;
      }
      cout<<sum<<endl;
    }
    return  0;
}

参考Java代码:

import java.util.Scanner;

public class Main {
	public static void main(String[] args) {

	    Scanner scanner = new Scanner(System.in);
        while (scanner.hasNext()) {
	        int sum=0;
		    int n = scanner.nextInt();
		    if(n==0) 
		        break;
		    while (n--!=0){
			     int a=scanner.nextInt();
		         sum=sum+a;
		    }
		    System.out.println(sum);
		    
		}
	}
}

参考Python代码:

while True: 
  sum=0 
  list=input().split()
  if list[0]=='0':
      break 
  for i in range(1,len(list)):
      list[i]=int(list[i])
      sum+=list[i]
  print(sum)



本文固定URL:https://www.dotcpp.com/course/825

Dotcpp在线编译      (登录可减少运行等待时间)